[Berbagi] Script Update Mikrotik dengan Dynamic IP4 ke TunnelBroker IPV6

Discussion in 'Masalah Teknik dan Keamanan' started by mnordins, 17 Feb 2015.

Thread Status:
Not open for further replies.
  1. mnordins

    mnordins Apprentice 1.0

    Messages:
    527
    Likes Received:
    66
    Trophy Points:
    28
    Sekedar melakukan percobaan untuk menambahkan koneksi IPv6 melalui Speedy di wilayah Kampoeng Cyber Yogyakarta. Dan hasilnya :

    [​IMG]
    Ping dari client

    [​IMG]
    IPv6 test dari client...

    Dikarenakan koneksi kampoengcyber menggunakan Speedy (yang berarti IP berada dibelakang NAT), maka diperlukan script untuk update IP4 host ke arah tunnel broker. Untuk hal tersebut, saya sedikit memodifikasi script dari forum mikrotik menjadi :
    Code:
    # Update Hurricane Electric IPv6 Tunnel Client IPv4 address
    
    :local HEtunnelinterface "<interface 6To4>"
    :local HEtunnelid "<Tunnel ID>"
    :local HEusername "<HE Username>"
    :local HEpassword "<HE Password>"
    :local HEupdatehost "ipv4.tunnelbroker.net"
    :local HEupdatepath "/nic/update"
    :local WANinterface "<WAN>"
    :local outputfile ("HE-" . $HEtunnelid . ".txt")
    
    # Internal processing below...
    # ----------------------------------
    :local HEipv4addr
    
    # Get WAN interface IP address
    :set HEipv4addr [/ip address get [/ip address find interface=$WANinterface] address]
    :set HEipv4addr [:pick [:tostr $HEipv4addr] 0 [:find [:tostr $HEipv4addr] "/"]]
    
    :if ([:len $HEipv4addr] = 0) do={
       :log error ("Could not get IP for interface " . $WANinterface)
       :error ("Could not get IP for interface " . $WANinterface)
    }
    
    # Update the HEtunnelinterface with WAN IP
    /interface 6to4 {
       :if ([get ($HEtunnelinterface) local-address] != $HEipv4addr) do={
          :log info ("Updating " . $HEtunnelinterface . " local-address with new IP " . $HEipv4addr . "...")
          set ($HEtunnelinterface) local-address=$HEipv4addr
       }
    }
    
    :log info ("Updating IPv6 Tunnel " . $HEtunnelid . " Client IPv4 address to new IP " . $HEipv4addr . "...")
    /tool fetch mode=http \
                      host=($HEupdatehost) \
                      url=("http://" . $HEupdatehost . $HEupdatepath . \
                              "?username=" . $HEusername . \
                              "&pass=" . $HEpassword . \
                              "&hostname" . $HEtunnelid . \
                              "&myip=" . $HEipv4addr) \
    
                      dst-path=($outputfile)
    
    :log info ([/file get ($outputfile) contents])
    /file remove ($outputfile)
    
    Pengaturan selebihnya, saya hanya mengikuti pengaturan dari dalam dashboard TunnelBroker, dan menambahkan IPv6 DHCP server ke arah klien.

    Selamat datang IPv6!

    PS :
    Jika thread ini dirasa tidak pada tempatnya, mohon dipindahkan pada tempat semestinya.
     
    pluto01 likes this.
Loading...
Thread Status:
Not open for further replies.

Share This Page

Loading...