Mikrotik Blacklist SpamHaus IP Address

Discussion in 'Masalah Teknik dan Keamanan' started by voezie, 1 Dec 2014.

Thread Status:
Not open for further replies.
  1. voezie

    voezie Hosting Guru

    Messages:
    1,771
    Likes Received:
    212
    Trophy Points:
    63
    Halo,

    Mungkin berguna bagi user mikrotik untuk menangkal attack dari ip yang terdaftar di spamhaus, openbl dan dshiel dengan menggunakan script berikut dari terminal mikrotik:

    OpenBL
    Script ini akan mendownload file ip blacklist openbl sebagai file openbl.rsc ke router mikrotik
    Code:
    /system script add name="Download_openbl" source={/tool fetch url="http://182.16.245.99.com/openbl.rsc" mode=http;:log info "Downloaded openbl.rsc from Murah-Banget.com";}
    Script ini akan menghapus file yang lama dan menambahkan ip blacklist dari file yang baru di download
    Code:
    /system script add name="Replace_openbl" source={:foreach i in=[/ip firewall address-list find ] do={:if ( [/ip firewall address-list get $i comment] = "OpenBL" ) do={/ip firewall address-list remove $i}}
    /import file-name=openbl.rsc;:log info "Removal old openbl and add new";}
    Script ini akan melakukan download file ip blacklist terbaru tiap 7hari
    Code:
    /system scheduler add comment="Download openbl list" interval=7d name="DownloadBegoneList" on-event=Download_openbl start-date=jan/01/1970 start-time=01:05:00
    /system scheduler add comment="Apply openbl List" interval=7d name="InstallBegoneList" on-event=Replace_openbl start-date=jan/01/1970 start-time=01:15:00
    Untuk direct link file ip blacklist lainnya dapat diakses/download di:

    http://182.16.245.99/openbl.rsc
    http://182.16.245.99/spamhaus.rsc
    http://182.16.245.99/dshield.rsc

    File tersebut auto-generated tiap 1jam
     
    Nina Prasetyo likes this.
  2. Nina Prasetyo

    Nina Prasetyo Expert 2.0

    Messages:
    970
    Likes Received:
    277
    Trophy Points:
    63
    Thx oom fauzi buat script-nya. Berguna banget ini. Semoga di update terus ... :113:
     
Loading...
Thread Status:
Not open for further replies.

Share This Page

Loading...