Mengatasi ini_set() has been disabled

Discussion in 'Masalah Teknik dan Keamanan' started by Asep Nugraha, 19 Aug 2014.

Thread Status:
Not open for further replies.
  1. Asep Nugraha

    Asep Nugraha Beginner 2.0

    Messages:
    41
    Likes Received:
    3
    Trophy Points:
    8
    Hallo semua,

    dari kemarin website tama tidak bisa kebuka, tapi web client normal...
    sempet kepikir karena dedicated IP (mungkin) atau masalah di httacces...

    tetap masih ga bisa kebuka!
    saya cb cek di intodns dan network-tools.com semua normal
    login cpanel (menggunakan ip) bisa

    saya cek di log, saya menemukan hal spt ini:

    [18-Aug-2014 06:00:10 UTC] PiHP Warnng: ini_set() has been disabled for security reasons in /home/usercpanel/public_html/wp-includes/load.php on line 271

    bagaimana mengatasi hal seperti ini?

    Terima Kasih
     
  2. ceo.ahlul

    ceo.ahlul Expert 1.0 Web Hosting (Company)

    Messages:
    622
    Likes Received:
    255
    Trophy Points:
    63
    coba tambahkan php.ini di dalam public_html dan wp-admin, isikan:

    Code:
    disable_functions = ''
    date.timezone = 'Asia/Jakarta'
    Jika maish tidak bsia, coba masnya meminta bantuan ke hostingnya.

    Catatan: Kalau skrip masnya ada memakai skrip yang terencode semisal memakai ioncube atau zend mungkin bisa bantuan juga ke hostingnya untuk mengetahui informasi path ke dua ekstensi tersebut agar ditambahkan ke php.ini nya.
     
  3. Asep Nugraha

    Asep Nugraha Beginner 2.0

    Messages:
    41
    Likes Received:
    3
    Trophy Points:
    8
    makasih pak @ceo.ahlul respon nya,

    saya sudah tambahkan php.ini tp masih blm jalan web nya.
    untuk akses root server saya sendiri yg pegang, untuk mengetahui info path nya dimana ya pak?
     
  4. ceo.ahlul

    ceo.ahlul Expert 1.0 Web Hosting (Company)

    Messages:
    622
    Likes Received:
    255
    Trophy Points:
    63
    Mungkin kalau masnya yang pegang akses root nya bisa di modifikasi php ini induknya mas.

    Kalau semisal itu cpanel biasanya di: /usr/lib/php.ini

    Lalu dihilangkan ini_set di pada parameter disable_functions di dalam file tersebut, dna di save kembali. Selanjutnya jika diperlukan di restart apachenya.
     
  5. Asep Nugraha

    Asep Nugraha Beginner 2.0

    Messages:
    41
    Likes Received:
    3
    Trophy Points:
    8
    @ceo.ahlul
    ini_set sudah dihapus dibagian disable_function nya..saya cb restrt jg apache (yup pak saya pakai cpanel)

    tp blm jg ya pak...mungkn bisa di cek di disana digitalcikarang-com, apakah sudah running atau masih blm
     
  6. ceo.ahlul

    ceo.ahlul Expert 1.0 Web Hosting (Company)

    Messages:
    622
    Likes Received:
    255
    Trophy Points:
    63
    Ini kelihatannya webnya yang tidak bisa diakses total mas, coba di cek apakah port 80 nya terblokir? atau apakah service apache nya jalan?

    Karena saya coba port 80 ga bisa diakses, port cpanelnya bisa diakses.
     
  7. dhyhost

    dhyhost Hosting Guru Web Hosting

    Messages:
    3,950
    Likes Received:
    615
    Trophy Points:
    113
    saya coba akses dari sini yang http tidak bisa diakses
    tapi kalau yang httpsnya bisa
    namun masih muncul warning di browsernya karena masih ada beberapa gambar yang menggunakan link http
     
  8. Asep Nugraha

    Asep Nugraha Beginner 2.0

    Messages:
    41
    Likes Received:
    3
    Trophy Points:
    8
    @ceo.ahlul web utama menggunakan dedicated IP, sementara client pakai shared ip...apa masalah nya disana?
    karena semua service berjalan normal di WHM.

    dedicated kemarin itu maksud nya mau saya pasang ssl gitu,

    @dhyhost sepertinya ada kesalahan di setting ssl nya kali ya..

    kayanya masalah di pemasangan ssl pak @ceo.ahlul karena kl pake https dia kebuka...

    hmmm, cb saya set ulang ssl nya ...
     
  9. Asep Nugraha

    Asep Nugraha Beginner 2.0

    Messages:
    41
    Likes Received:
    3
    Trophy Points:
    8
    Alhamdulillah, semua sudah fix sepertinya..setelah ssl di install dgn bener....
    @dhyhost @ceo.ahlul
     
Loading...
Thread Status:
Not open for further replies.

Share This Page

Loading...