Upgrade to OpenSSH 9.8 or later

komputerserver

Apprentice 1.0

Jutaan server OpenSSH dapat terpengaruh oleh kerentanan baru yang dapat dieksploitasi untuk eksekusi kode jarak jauh yang tidak diautentikasi.
Cacat tersebut, dilacak sebagai CVE-2024-6387 dan diberi nama regreSSHion, ditemukan oleh unit penelitian ancaman di perusahaan keamanan siber Qualys. Kerentanan ini digambarkan sebagai hal yang kritis dan sama seriusnya dengan kerentanan Log4Shell pada tahun 2021.
Peneliti perusahaan menemukan bahwa proses server OpenSSH 'sshd' dipengaruhi oleh kondisi pengendali sinyal yang memungkinkan eksekusi kode jarak jauh yang tidak diautentikasi dengan hak akses root pada sistem Linux berbasis glibc. Tidak jelas apakah eksploitasi pada sistem Windows dan macOS mungkin dilakukan.

Eksploitasi kerentanan regresi dapat menyebabkan pengambilalihan sistem secara menyeluruh, memungkinkan instalasi malware dan pembuatan pintu belakang.


How to Check

How to Fix

Pelanggan disarankan untuk meningkatkan ke OpenSSH 9.8 atau lebih baru untuk mengatasi kerentanan ini. Patch ini mengatasi kelemahan validasi masukan, memastikan bahwa permintaan yang dibuat khusus tidak dapat mengeksploitasi kerentanan.
 
dpkg -l openssh* | grep ssh
ii openssh-client 1:8.2p1-4ubuntu0.11 amd64 secure shell (SSH) client, for secure access to remote machines
ii openssh-server 1:8.2p1-4ubuntu0.11 amd64 secure shell (SSH) server, for secure access from remote machines
ii openssh-sftp-server 1:8.2p1-4ubuntu0.11 amd64 secure shell (SSH) sftp server module, for SFTP access from remote machines
un openssh-sk-helper <none> <none> (no description available)

bagaimana cara upgrade nya Kak ?
 
sudo apt update openssh-server -y

pakai itu tidak jalankah ?

sudah, tidak ada perubahan Kak

koreksi, bisa harus hapus openssh-server & openssh-client terlebih dahulu
sudo systemctl stop sshd
sudo apt-get remove openssh-server openssh-client
apt install openssh-server openssh-client

dpkg -l openssh* | grep ssh
dpkg-query: no packages found matching openssh-9.8p1.tar.gz

ssh -V
OpenSSH_9.6p1 Ubuntu-3ubuntu13.3, OpenSSL 3.0.13 30 Jan 2024
 
Last edited:
Kalau yg saya baca dr forum centmin sepertinya hanya El9 yg kena dampak untuk varian centos alma rocky
untuk rhel 6 7 8 termasuk almalinux 8 safe karna alma juga keluarin versi updatenya cm buat el9.


1000205159.jpg
 
ssh -V
OpenSSH_9.6p1 Ubuntu-3ubuntu13.3, OpenSSL 3.0.13 30 Jan 2024

Code:
Changelog
openssh (1:9.6p1-3ubuntu13.3) noble-security; urgency=medium

  * SECURITY UPDATE: remote code execution via signal handler race
    condition (LP: #2070497)
    - debian/patches/CVE-2024-6387.patch: don't log in sshsigdie() in log.c.
    - CVE-2024-6387
 
Back
Top