{ask} Error Install Ion cube loader!


Status
Not open for further replies.

Mahavikri

Apprentice 1.0
halo semua,

gw lagi ada masalah di kit nih, kemarin abis rebuild apache ke apache 2.2.1 , php 5.2.9, dan pasang beberapa ekstension lainnya (zend optimizer, ion cube, curl, dsb).

Tapi setelah rebuild selesai tidak ada pilihan untuk versi PHPnya

Option Value
Default PHP Version (.php files)
PHP 5 Handler None
PHP 4 Handler None
Suexec On
lalu webnya pada ga bisa di akses nih :(

root@kadisoka [~]# php -v
The ionCube PHP Loader is disabled because of startup problems.
Segmentation fault
root@kadisoka [~]#
gimana cara fixnya yah...? supaya ioncube bisa jalan normal :confused:

OSnya pake CENTOS 5.3 x86_64

Thanks.
 
Last edited:

susan

Apprentice 2.0
sebenarnya kalau mau install ioncube tidak perlu rebuild apache, cukup dari shell jalankan:
Code:
/scripts/phpextensionmgr install IonCubeLoader
susan,
 

Mahavikri

Apprentice 1.0
bro, masih tetep error dan keluar:
The ionCube PHP Loader is disabled because of startup problems.
root@kadisoka [~]# /scripts/phpextensionmgr install IonCubeLoader
Updating md5sum list
Fetching http://httpupdate.cpanel.net/cpanelsync/easy/targz.yaml (0)....@69.72.212.11......connected......receiving...100%......Done
Installing IonCubeLoader
Determining PHP version
Installing IonCube Loader binaries
Activating IonCube Loader extension in /usr/local/lib/php.ini
IonCube Loader extension activated
root@kadisoka [~]# php -v
The ionCube PHP Loader is disabled because of startup problems.
PHP 5.2.9 (cli) (built: Apr 22 2009 06:10:30)
Copyright (c) 1997-2009 The PHP Group
Zend Engine v2.2.0, Copyright (c) 1998-2009 Zend Technologies
with the ionCube PHP Loader v3.1.34, Copyright (c) 2002-2009, by ionCube Ltd., and
root@kadisoka [~]#
gmn yah :confused:
 

YosDuoS

Poster 1.0
cek php.ini nya


/usr/local/lib/php.ini

bagian ini:

Code:
; Directory in which the loadable extensions (modules) reside.
extension_dir = "/usr/local/lib/php/extensions/no-debug-non-zts-20060613"
[B]zend_extension="/usr/local/IonCube/ioncube_loader_lin_5.2.so"
zend_extension_ts="/usr/local/IonCube/ioncube_loader_lin_5.2_ts.so[/B]"
mungkin disitu masalahnya

ref: http://supportfacility.com/blog/install/how-to-install-ioncube-on-cpanel-dedicated-server/
 

Mahavikri

Apprentice 1.0
ok Tuan mantab... dha jalan lage,, thanks all :D


root@kadisoka [~]# php -v
PHP 5.2.9 (cli) (built: Apr 25 2009 08:10:50)
Copyright (c) 1997-2009 The PHP Group
Zend Engine v2.2.0, Copyright (c) 1998-2009 Zend Technologies
with eAccelerator v0.9.5.3, Copyright (c) 2004-2006 eAccelerator, by eAccelerator
with the ionCube PHP Loader v3.1.34, Copyright (c) 2002-2009, by ionCube Ltd., and
with Zend Extension Manager v1.2.2, Copyright (c) 2003-2007, by Zend Technologies
with Zend Optimizer v3.3.3, Copyright (c) 1998-2007, by Zend Technologies
root@kadisoka [~]#
 
Status
Not open for further replies.

Top