[ASK] Setting Nat Proxmox


donquixote

Beginner 1.0
diketahui :
Versi tertera di port 8006 Proxmox Virtual Environment 6.4-13

uname -a
Linux server 5.4.157-1-pve #1 SMP PVE 5.4.157-1 x86_64 GNU/Linux

ip publik 150.25.69.210 (bukan ip sebenarnya)

cat /etc/network/interfaces
----------------
auto lo
iface lo inet loopback

iface enp1s0 inet manual

auto vmbr0
iface vmbr0 inet static
address 150.25.69.210/24
gateway 150.25.69.210
bridge-ports enp1s0
bridge-stp off
bridge-fd 0
auto vmbr1
iface vmbr1 inet static
address 10.10.10.1/24
bridge_ports none
bridge_stp off
bridge-fd 0
------------------------

setting network di Containernya (LXC) <<< Alpine Linux
-------------------
Name | Bridge | Firewall | Ip Address | Gateway
eth0 | vmbr1 | no | 10.10.10.20/24 | 10.10.10.1

hasil Alpine linux tidak bisa ping kemana pun baik google.com atau 8.8.8.8 atau ip publik lain


coba ikutin dokumentasi

edit etc/network/interfaces
----
auto lo
iface lo inet loopback

auto enp1s0
#real IP address
iface enp1s0 inet static
address 150.25.69.210/24
gateway 150.25.69.1

auto vmbr0
#private sub network
iface vmbr0 inet static
address 10.10.10.1/24
bridge-ports none
bridge-stp off
bridge-fd 0

post-up echo 1 > /proc/sys/net/ipv4/ip_forward
post-up iptables -t nat -A POSTROUTING -s '10.10.10.0/24' -o enp1s0 -j MASQUERADE
post-down iptables -t nat -D POSTROUTING -s '10.10.10.0/24' -o enp1s0 -j MASQUERADE
-----

coba in configurasi ini, terus setting yg di Alpine Linuxnya
ip Address 10.10.10.20/24
gatewaynya 10.10.10.1

yang ada server malah down tidak bisa diakses di ping RTO
lalu coba iseng buat tiket dengan bilang bahwa saya tidak bisa connect ssh,
lalu dia minta izin untuk aktifin rescue mode
saat dia utak atik di rescue mode sy coba ping ke ip public saya dan hasilnya normal...

setelah beberapa saat, admin yang menangani mengatakan bahwa ini server saya berjalan dengan normal..

sy jelaskan bahwa saat coba rescue mode aman-aman saja tetapi saat coba mode normal tidak bisa connect..
lalu dengan binggung dan coba cek dan utak atik rescue mode adminya berkesimpulan bahwa server saya rusak di bagian hardware :65:
dan dia minta maaf, dan memberikan solusi untuk refund atau buat penganti server yang baru.

dengan polosnya saya meminta silahkan ganti unit saja.

setelah digantinya server baru saya mencoba mengulangi kesalahan yang sama,
karena saya fikir settingan ini benar dan sudah mengikuti dokumentasi dengan seksama,
kejadian terulang server down, kali ini saya coba memasuki rescue mode sendiri, dan coba merubah etc/network/interface ke semula agar aktif kembali..
dan BERHASIL :cheer2:


permasalahan :

hingga saat tulisan ini alpine linux masih tidak bisa ping kemana-mana.
mohon pencerahannya bagaimana setting yang benar agar alpine linux bisa akses internet :77:
 

Milea Adnan

Expert 1.0
sewa DS nya apakah di OVH ?
Kalo iya, OVH punya setingan network yg lain daripada yg lain, tidak bisa pakai setingan yang ada di dokumentasinya proxmox sekalipun.
 

donquixote

Beginner 1.0
dns nya sudah di setting kak ?

sudah tuan :18:
tapi yaa masih saja, belum terpecahkan, coba pakai referensi dari tuan https://www.diskusiwebhosting.com/t...edicated-server-1-ip-public.34550/post-259891

masih tidak bisa


sewa DS nya apakah di OVH ?
Kalo iya, OVH punya setingan network yg lain daripada yg lain, tidak bisa pakai setingan yang ada di dokumentasinya proxmox sekalipun.

Bukan di OVH Tuan, maksudnya setingan networknya berbeda? bisa kasih tau tuan atau ada referensi yang bisa saya baca-baca
 

hostnic.id

Hosting Guru
Verified Provider
Buat refrensi aja kak mungkin bisa di coba , ini settingan proxmox internal saya

=== disisi proxmox ======

source /etc/network/interfaces.d/*

auto lo
iface lo inet loopback

auto eno1
iface eno1 inet manual

iface eth0 inet manual

iface eth1 inet manual

auto vmbr0
iface vmbr0 inet static
address 172.20.0.205/24
gateway 172.20.0.1
bridge-ports eno1
bridge-stp off
bridge-fd 0
# post-up echo 1 > /proc/sys/net/ipv4/conf/eth0/proxy_arp
auto vmbr1
iface vmbr1 inet static
address 192.168.90.1/24
bridge-ports none
bridge-stp off
bridge-fd 0


post-up echo 1 > /proc/sys/net/ipv4/ip_forward
post-up iptables -t nat -A POSTROUTING -s '192.168.90.0/24' -o vmbr0 -j MASQUERADE
post-down iptables -t nat -D POSTROUTING -s '192.168.90.0/24' -o vmbr0 -j MASQUERADE

==== enable ipv4 forward ====
nano /etc/sysctl.conf

enable
net.ipv4.ip_forward=1

==== Alpine linux =====


test-alphine1:~# uname -a
Linux test-alphine1 5.13.19-1-pve #1 SMP PVE 5.13.19-3 (Tue, 23 Nov 2021 13:31:19 +0100) x86_64 Linux
test-alphine1:~# ping google.com
PING google.com (142.251.12.139): 56 data bytes
64 bytes from 142.251.12.139: seq=0 ttl=56 time=15.913 ms
64 bytes from 142.251.12.139: seq=1 ttl=56 time=15.654 ms
^C
--- google.com ping statistics ---
2 packets transmitted, 2 packets received, 0% packet loss
round-trip min/avg/max = 15.654/15.783/15.913 ms
test-alphine1:~# cat /etc/network/interfaces
auto eth0
iface eth0 inet static
address 192.168.90.11
netmask 255.255.255.0
gateway 192.168.90.1
 


Top