Web statistic Allstats & GHOST++


Status
Not open for further replies.

RioteR

New Member
Salam kenal, saya member baru disini, tolong dibantu ya :)

Saya sedang utak-atik program Bot DotA (Bot untuk create room, GHost++) & Web statistic (Allstats), mereka running smoothly jika jalan di localhost, saya menggunakan Web Developer Controller (WAMP). Saya online-kan melalui IP public saya tidak ada masalah (tapi kalo laptop saya offline jelas tidak bisa diakses)

Web saya upload di webhosting (gratisan) : http://dotastatistic.000space.com/ , nah di cpanel itu kan ada hostname, mysql user, mqsql password dll.

confignya web statisticnya :
Code:
/MySQL Database Connection information (Optional):
//Must correspond to the settings in your MySQL Database.
$host = 'sql103.000space.com';
$username = 'space_*****';
$password = '*****';
$databasename = 'space_*****';
config di ghost :
### mysql database configuration
### this is only used if your database type is MySQL

Code:
db_mysql_server = sql103.000space.com
db_mysql_database = space_*****
db_mysql_user = space_*****
db_mysql_password = *****
db_mysql_port = 3306
Jika pakai database online, Ghost++ tiak mau running, error : cant connect mysql database

Quote dari tutorial :
GHOST++ dan Website statistik HARUS AKSES DATABASE YANG SAMA. Hal ini bisa dilakukan dengan configure mysql user agar bisa remote acces , jadi putuskan database akan disimpan dimana, apakah di PC ghost++ atau di PC website. Configure server mysql di config setiap bot untuk akses ke IP Public , bukan localhost. Lebih jelas soal ini pelajari tentang hosting dan mysql dan konsultasi dengan tempat hosting
If using MySQL and MySQL is running on a remote computer:
- Set db_type = mysql
- Set db_mysql_server = IP of the remote computer
- Set db_mysql_port = the port specified by your web host
- Make sure that you have given permission for your local computer to access MySQL or you won't be able to connect.
Ini permasalahannya saya lihat access database di remote computer, padahal di web hosting kan tidak ada IP nya, saya coba ping host nya malah RTO, CMIIW :)

Jadi bagaimana mengatasi masalah ini?
 

RioteR

New Member
db_mysql_server = localhost, ghostnya jalan, tapi web statisticnya tidak

tambahan
webstatistic (gw upload juga 000webhost.com)
eror :
Warning: mysql_connect() [function.mysql-connect]: Access denied for user 'a1596211_ghost'@'localhost' (using password: YES) in /home/a1596211/public_html/config.php on line 203
Free Web Hosting

Not connected : Access denied for user 'a1596211_ghost'@'localhost' (using password: YES)
misal db_mysql_server = localhost, lha si webstatistic apa mau update otomatis mengingat web & database berada di server web hosting, eror kaya yang diatas.

masih bingung
 

RioteR

New Member
Saya share saja :o

Pada web statistic saya http://statsdota.herobo.com/

config.php

//SQLite Database Connection information (Optional):
//dbLocation must point to your SQLite Database.
//$dbLocation = './ghost.dbs';

//MySQL Database Connection information (Optional):
//Must correspond to the settings in your MySQL Database.
$host = 'mysql16.000webhost.com';
$username = 'a1596211_ghost';
$password = 'b4jingb0t';
$databasename = 'a1596211_bot';
» MySQL Database » MySQL User » MySQL Host
a1596211_bot a1596211_ghost mysql16.000webhost.com

----------------------------------------------------------------------------------
Pada aplikasi Ghost++

ghost.cfg

##########################
# DATABASE CONFIGURATION #
##########################

### database type
### use "sqlite3" for a local SQLite database
### use "mysql" for any MySQL database

db_type = mysql

### sqlite3 database configuration
### this is only used if your database type is SQLite

db_sqlite3_file =

### mysql database configuration
### this is only used if your database type is MySQL

db_mysql_server = localhost
db_mysql_database = a1596211_bot
db_mysql_user = a1596211_ghost
db_mysql_password = b4jingb0t
db_mysql_port = 3306
@rendy
apakah user a1596211_ghost sudah diberikan permission ke database bersangkutan?
eror yg sebelumya td gara2 di config.php di web hosting saya ganti ke localhost :p


Jadi gini, user 'a1596211_ghost' saya create di web hosting beserta passwordnya, lalu saya create database 'a1596211_bot' dengan mengimport database 'bot' yang ada di localhost.

bahkan saya create ulang database di localhost dengan nama 'a1596211_bot' dengan user 'a1596211_ghost' dengan privleges = root , lalu saya upload ke web hosting dengan drop table yang ada sebelumnya

Mohon pencerahan para suhu :(
 

rendy

Hosting Guru
Verified Provider
di konfigurasi database server udah di set prev = all belum? si user ghost itu?
baru di mention localhost saja ya yang di set prev nya
 
Status
Not open for further replies.

Top